Junk Filtering How-To

From Npserv-help
Jump to: navigation, search

Enabling Junk Filtering

  • Click on the "Edit" menu
  • Click on "Account Settings"
  • Under your email account, click on "Junk Settings"
  • Check "Enable adaptive junk mail controls for this account"
  • Check "Do not mark mail as junk if the sender is in:"
  • Choose an Address Book folder.
  • Check "Move new junk messages to:"
  • Choose the folder you want your junk mail to go to.

Thunderbird-junk-filter-1.png

Marking a message as Junk

  • In order to "train" Thunderbird on the types of messages that are considered junk, you have to mark these messages as junk.
  • To do this, click the circle under the junk column (usually between the sender and date columns). The heading should be a flame or recycle symbol. This is the junk indicator. You can toggle it on and off for each message. You can also use the "Junk" button in the toolbar.
  • The more messages you manually flag as junk, the more Thunderbird will "learn" what to flag automatically.

Thunderbird-junk-filter-2.png

Viewing your Junk Folder

  • After "training" Thunderbird on what it should consider junk, it should automatically move junk messages to the "Junk" folder.
  • You can click on the Junk folder in the folder list to view junk messages.

Thunderbird-junk-filter-3.png


Troubleshooting

Sometimes junk messages are not automatically moved to the junk folder

  • When this happens...
  • Click on the "Tools" Menu
  • Click on "Run Junk Mail Controls on Folder"
  • It may appear like nothing is happening, but Thunderbird is actually reading through all the emails in the current folder and detecting if they are junk or not. You can see the progress of this task in the status bar at the bottom.

Thunderbird-junk-filter-4.png

Non-junk messages are being marked as junk

  • If a lot of legitimate messages are being automatically marked as junk, you can reset the training data. *Note* After you do this, you will have to re-train Thunderbird if you want to filter junk mail again.
  • Click on the "Edit" menu
  • Click on "Preferences"
  • Click on "Privacy"
  • Click on the "Junk" tab
  • Click the "Reset Training Data" button

Thunderbird-junk-filter-5.png